Go Back   WorldwideDX Amateur Radio Forums > Amateur Radio Related > Amplifiers


Amateur Callsign Lookup
Enter Callsign:

Texas Star Amp Repair free help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-25-2010, 08:56 PM
TexasStarRepair's Avatar
Junior Member
iTrader: (1)
 
Join Date: May 2010
Location: Escondido, CA
Posts: 11
TexasStarRepair is on a distinguished road
Default Texas Star Amp Repair free help



a quarter century with Texas Star, and I have been put to pasture.
I did tech support for about 10 years. I am sure that some of you must know me.
It is my intention now to help techs and hobiests to repair a stock TS amplifier. I am not an engineer and there are things which I will not debate. However, I can usually fix one and not to have it blow itself up again.

I have made the simplest of web pages which I invite you to. Go to the troubleshooting page and pick up some pointers.
You can e-mail me with questions. I really like a digital picture with your question as a picture can be worth a thousand words. I may be able to recognize modifications or vintage of manufacture, or maybe even see a short or open from the pic.
I will try to come in here occasionally and look at the threads.

Remember, when you replace transistors on a Texas Star amp you need to check the bias circuit or you may just blow the replacement finals.
1 extra minute is all I suggest. Read the bias resistance, then manually key up and read the bias voltages.
GO to YouTube and look for Texas star Amp Repair
you will find manual key-up procedure and bias check procedure.

My name is Mike and I hope that I can help some of you.

TexasStarRepair@cox.net
Home Page


Reply With Quote
  #2  
Old 05-25-2010, 09:04 PM
Robb's Avatar
Yup
iTrader: (3)
 
Join Date: Dec 2008
Location: Silicon Valley CA, Storm Lake IA
Posts: 7,829
Robb is on a distinguished road
Default

Thanks Mike, we do from time to time have some questions about amps and repair.

WE ALSO HAVE SOME HEALTHY DEBATES THAT YOU MAY WANT TO READ OR PERHAPS EVEN GET INVOLVED IN!!!

Welcome to the forum
__________________
BASE: Kenwood TS-2000, GAP Titan DX, Diamond X50A, Sirio SY27-4, and IMAX 2000.
MOBILE: Galaxy DX99V w/RF Limited CR-577 mic, Sirio Z-180. Yaesu FT-8800R & Diamond NR-770.

Reply With Quote
  #3  
Old 05-25-2010, 09:36 PM
BOOTY MONSTER
Guest
 
Posts: n/a
Default

welcome to the forum , glad to see you found the place and i really look forward to your comments .

Reply With Quote
  #4  
Old 05-26-2010, 04:20 AM
AudioShockwav's Avatar
Extraterrestrial Admin
iTrader: (2)
 
Join Date: Apr 2005
Location: High Sierras Near Yosemite Nat Park
Posts: 5,055
AudioShockwav has disabled reputation
Default

I Asked Mike If we could put a link up to his site, and if he would be willing to come over and have a look at the forum.
He has graciously said yes, and I want to Thank Him for coming over and offering his help to the Members.
This post is going to be sticky'ed to the top for easy access.

If you guys will visit Mike`s Home Page( link at the bottom of his first post), and Have a Look At his Trouble Shooting Section, you will find an awesome Guide on how to troubleshoot T/S amps, with step by Step Details , what to look for and do, as well as how to test transistors in the Amps and lots More great Info.

Again, Thanks Mike, and Welcome to the Forum!

73
Jeff
__________________
Radio-active

NASA/SOHO


When I was a child
I caught a fleeting glimpse
Out of the corner of my eye.
I turned to look but it was gone
I cannot put my finger on it now
The child is grown,
The dream is gone.
but I have become comfortably numb.

Reply With Quote
  #5  
Old 05-26-2010, 04:42 PM
airplane1's Avatar
W9WDX Amateur Radio Club Member
iTrader: (2)
 
Join Date: Apr 2005
Location: PA
Posts: 1,131
airplane1 is on a distinguished road
Default

Welcome Mike

Reply With Quote
  #6  
Old 05-26-2010, 05:26 PM
Jock Supporter
iTrader: (8)
 
Join Date: Feb 2008
Posts: 7,534
mackmobile43 is on a distinguished road
Default

Yo, sup?

Reply With Quote
  #7  
Old 05-27-2010, 04:08 AM
airplane1's Avatar
W9WDX Amateur Radio Club Member
iTrader: (2)
 
Join Date: Apr 2005
Location: PA
Posts: 1,131
airplane1 is on a distinguished road
Default

I checked out your youtube posts on the amp diagnosis, Cool, I am going to check my 250 HDV tonight. I never did get it fixed. I searched more on the TS amps on youtube and seen how they are supposed to work correctly. I see that on ssb the relay clicks on and stays on while talking, then it clicks off a split second after talking stops. Mine always clicked on and off fast with my peaks and lows of my voice. People said they would here my clicking while I talked but other than that it sounded great.

Now the amp chatters fast all the time. It never worked like it should.

The one youtube vidio says there is a resistor or capacitor that holds the relay in so it dont chatter while ssbing.

AP

Last edited by airplane1; 05-27-2010 at 04:12 AM. Reason: add info

Reply With Quote
  #8  
Old 05-28-2010, 01:28 PM
TexasStarRepair's Avatar
Junior Member
iTrader: (1)
 
Join Date: May 2010
Location: Escondido, CA
Posts: 11
TexasStarRepair is on a distinguished road
Default

thanks all, glad to help where I can

Airplane
email me direct with a clear digital picture of the amp board.

all of our amps had a 1000 uF electrolytic cap behind relay.
There should be a delay on and off switch.

Describe your problem in the e-mail and we will go from there.
Mike

Reply With Quote
Reply

Bookmarks
Worldwide Radio Forum



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
LOOKING FOR SOMEONE TO REPAIR A TEXAS STAR 500 TonyV225 Amplifiers 8 08-13-2009 08:44 PM


All times are GMT -7. The time now is 05:12 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Worldwide Radio Forum