Go Back   WorldwideDX Amateur Radio Forums > Citizens Band Related > CB Band and CB Radios


Amateur Callsign Lookup
Enter Callsign:

Problem with 29 NW ltd classic

Like Tree1Likes
  • 1 Post By pede69

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-05-2012, 09:30 AM
Junior Member
iTrader: (0)
 
Join Date: Mar 2012
Posts: 2
Country boy smith is on a distinguished road
Default Problem with 29 NW ltd classic


I just bought and installed a new cobra 29 NW ltd classic but my antenna warning light is coming on.. I've checked everything that I know and added a ground wire to the mounting bracket to the chasis and still doesn't want to work and the dimmer control only works on the meter and channel display opposed to lighting up all the functions. Same antenna and wiring worked fine for my cobra 19 plus.. any ideas or help would be great


Reply With Quote
  #2  
Old 03-05-2012, 10:30 AM
Member
iTrader: (0)
 
Join Date: Sep 2010
Posts: 33
pede69 is on a distinguished road
Default

Unless you have a damaged radio (new or not) you have a problem in your antenna system. Check for a short and put an SWR meter on it. Even if it worked (or seemed to be working correctly) or not.

The 19 has no SWR warning light. You may have had the problem and did not know it.

As far as the lights go, the dimmer is working correctly. Does not control the panel brightness.

John
AudioShockwav likes this.

Reply With Quote
  #3  
Old 03-05-2012, 01:29 PM
Junior Member
iTrader: (0)
 
Join Date: Mar 2012
Posts: 2
Country boy smith is on a distinguished road
Default

You mean a short in the coax? And as far as the dimmer it controlled the panel before but now it wont

Reply With Quote
  #4  
Old 03-05-2012, 02:42 PM
psycho's Avatar
Supporting Member
iTrader: (0)
 
Join Date: Aug 2006
Location: With Your Wife
Posts: 2,976
psycho is on a distinguished road
Default

Quote:
Originally Posted by Country boy smith View Post
I just bought and installed a new cobra 29 NW ltd classic but my antenna warning light is coming on.. I've checked everything that I know and added a ground wire to the mounting bracket to the chasis and still doesn't want to work and the dimmer control only works on the meter and channel display opposed to lighting up all the functions. Same antenna and wiring worked fine for my cobra 19 plus.. any ideas or help would be great

Unless you check the swr, there is no sense going any further. Some antenna warning indicators light at 2-1 swr while others light at 2.5-1.
__________________
Stop staring at me!

Reply With Quote
Reply

Bookmarks
Worldwide Radio Forum



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Circuit Improvements and Maintenance Procedures for the TS-830S AudioShockwav Kenwood 1 08-18-2011 10:28 AM
Circuit Improvements for the TS-440S AudioShockwav Kenwood 0 08-17-2011 11:34 AM
Another 29LTD classic problem badfish General CB Services Discussion 12 01-24-2011 08:11 PM
Cobra 29 LTD Classic problem Raccoon CB Band and CB Radios 4 08-18-2009 05:42 PM
New Antenna = Problem jdgee CB Band and CB Radios 6 04-07-2005 08:52 AM


All times are GMT -7. The time now is 11:21 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Worldwide Radio Forum