Go Back   WorldwideDX Amateur Radio Forums > Citizens Band Related > CB Band and CB Radios


Amateur Callsign Lookup
Enter Callsign:

president washington problems

Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-16-2013, 03:28 PM
Junior Member
iTrader: (0)
 
Join Date: Nov 2012
Location: texas
Posts: 19
red97k1500 is on a distinguished road
Default president washington problems


I recently bought a president washington base station radio.it worked ok powered up and everything fine... people say it has good signal, but low modulation. So today i gently blew the radio out with compressed air. both covers are off. i plug it into the wall and it powers up for just a second then dies.i have checked the fuse in the back of the radio and its good.any sugestions on why this thing wont power up. I never saw any smoke or anything.... i was carefull while i was blowing all the dust out of the radio.


Reply With Quote
  #2  
Old 01-16-2013, 03:45 PM
ExitThirteen's Avatar
Grumpy, Cranky Repairman
iTrader: (11)
 
Join Date: Apr 2008
Location: Cornpatch of Iowa
Posts: 1,051
ExitThirteen is on a distinguished road
Default

Check the AC/DC switch on the backside of the radio, and make sure it didn't get moved. If it's just a hair off of the AC position, it can potentially cause the issue you're having. Have a look and let us know how you get on.


~Cheers~
__________________
Bases: Cobra 2000 GTL, President Washington, President Madison, Tram D201A
Mobiles: Cobra 146GTL, Midland 79-893 (NIB), Midland 13-893 (27.555), President P300

Reply With Quote
  #3  
Old 01-16-2013, 04:07 PM
Junior Member
iTrader: (0)
 
Join Date: Nov 2012
Location: texas
Posts: 19
red97k1500 is on a distinguished road
Default

I did not know there was a switch i hope i have not damaged anything i have been plugging it in my house and in my truck without ever flipping this switch... i just plugged it into my truck not long ago and it powered up but there was no receive.... i need to check the switch for sure im guessing its under neath the covers

Reply With Quote
  #4  
Old 01-16-2013, 04:57 PM
ExitThirteen's Avatar
Grumpy, Cranky Repairman
iTrader: (11)
 
Join Date: Apr 2008
Location: Cornpatch of Iowa
Posts: 1,051
ExitThirteen is on a distinguished road
Default

Ohh! I bet you have the old school President Washington, with the 4 pin mic jack and the 2 push buttons in the front. In that case, you won't have an AC/DC switch in the back.


In this case, does it always power up for just a second before shutting down when trying to run it on 110V? Or did it do that just once, and now it's not powering up at all?

If it powers up on 12V, I'd suspect something in the power supply went fault.

Try keying up the radio in your vehicle. If you are able to key up on AM, but do not have any modulated audio, and no receive audio, I'd suspect a bad audio IC.


~Cheers~
__________________
Bases: Cobra 2000 GTL, President Washington, President Madison, Tram D201A
Mobiles: Cobra 146GTL, Midland 79-893 (NIB), Midland 13-893 (27.555), President P300

Reply With Quote
  #5  
Old 01-16-2013, 05:31 PM
Junior Member
iTrader: (0)
 
Join Date: Nov 2012
Location: texas
Posts: 19
red97k1500 is on a distinguished road
Default

Yes it is an old washington 4 pin mike jack, 858 pll chip.... and no before i blew it out it powered up fine when plugged into the wall.... the only problems with it before i blew it out was no modulation.... now it will power up in my truck on 12u volts but no receive... im about to do some reading up on it and try to fix it myself

Reply With Quote
  #6  
Old 01-16-2013, 05:56 PM
ExitThirteen's Avatar
Grumpy, Cranky Repairman
iTrader: (11)
 
Join Date: Apr 2008
Location: Cornpatch of Iowa
Posts: 1,051
ExitThirteen is on a distinguished road
Default

Could check the relay and see if it's come loose in the socket, or possibly dirty contacts. That can cause the receive to drop. Have a look at that too.


~Cheers~
RADIOOMAN likes this.
__________________
Bases: Cobra 2000 GTL, President Washington, President Madison, Tram D201A
Mobiles: Cobra 146GTL, Midland 79-893 (NIB), Midland 13-893 (27.555), President P300

Reply With Quote
  #7  
Old 01-16-2013, 05:59 PM
RADIOOMAN's Avatar
Senior Member
iTrader: (0)
 
Join Date: Jun 2012
Location: Indiana, North East, EN71
Posts: 428
RADIOOMAN is on a distinguished road
Default

Quote:
Originally Posted by ExitThirteen View Post
Could check the relay and see if it's come loose in the socket, or possibly dirty contacts. That can cause the receive to drop. Have a look at that too.


~Cheers~
Good thinking.
I forgot all about the relay.
Sometimes the wire retainer has been removed and is no longer present and could allow the relay to wiggle loose in the socket if the radio were to be moved around in different positions such as what might occur if you were to blow the dust out with compressed air.

Radiooman

Reply With Quote
  #8  
Old 01-16-2013, 08:46 PM
Junior Member
iTrader: (0)
 
Join Date: Nov 2012
Location: texas
Posts: 19
red97k1500 is on a distinguished road
Default

I got it to power up again when i plug it into the wall.All i did was pull out the relay and put it back in.Now its working the way it did before but kind of intermittently.When i plugged it back in at first only the meter light and channel display came on then i pushed the cb/pa switch a few times and played with mode switch and turned it off and on and the recieve came back.Btw this radio is bone stock from what i can tell.I dont think its ever been moded,clairifier is still locked etc.

Reply With Quote
Reply

Bookmarks
Worldwide Radio Forum



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
President Washington AM/SSB Base with Redco Digiscan wcsd106 CB Radio Gear SwapShop 0 12-05-2011 07:04 PM
PRESIDENT/UNIDEN RADIO ADJUSTMENTS AudioShockwav CB Radio Modifications 0 07-24-2011 03:01 PM
The ARRL Letter Vol. 26, No. 48 December 7, 2007 AudioShockwav FCC & ARRL Activity 0 12-10-2007 05:34 PM
Frequencies Charger383 Scanning & Shortwave Listening 8 08-21-2001 06:44 PM


All times are GMT -7. The time now is 07:37 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Worldwide Radio Forum