Go Back   WorldwideDX Amateur Radio Forums > Citizens Band Related > CB Band and CB Radios


Amateur Callsign Lookup
Enter Callsign:

Mirage 2950

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-07-2006, 02:42 AM
Junior Member
iTrader: (0)
 
Join Date: Mar 2006
Posts: 11
Texas Grizzly Bear is on a distinguished road
Default Mirage 2950


I have a Mirage 2950 which Iíve been using for a while now as a mobile. For those of you not familiar with this radio think RCI 2950. The radio has worked very well for me up until a few days ago. I noticed when I turned the radio on I couldnít hardly hear any thing (not even static) which is very odd around here. I tried calling out a few times to see if I could get a response without any luck. I had to make a quick stop at the store and when I came back out a friend was calling for me wanting to know why I hadnít answered his ďcallĒ. I told him I had not heard any one. To make a long story short Iíve noticed if I change the Ch. my SWRs are going through the roof (and my receive goes out the window), and the only way to reset them is to turn the radio off wait a few and turn it back on, when I turn it back on the radio works just fine (transmit and receive). Anybody have any ideas what might be going on. Iím getting ready to put my Galaxy 99 back in to see if the same thing starts to happen to it.

Thanks ahead of time for your responses,
Texas Grizzly Bear


Reply With Quote
  #2  
Old 04-07-2006, 05:20 AM
Happy_Hamer's Avatar
Forum Administrator
iTrader: (0)
 
Join Date: Mar 2001
Posts: 5,060
Happy_Hamer has disabled reputation
Default

I had the old 2950 and the rx went out because the ext speaker jack was shorted. Also I had alot of display problems. I replaced the internal battery and still no luck. I took it to a friend and he said go somewhere like walmart and buy the battery. I did that and it worked like a charm. The internal battery I bought at the local cb shop had been sitting forever apparently and was a piece of crap.

Check the 1/8 inch ext speaker jack
Replace the internal battery making sure you buy a good one
__________________
That's how I roll!!

Reply With Quote
  #3  
Old 04-07-2006, 05:43 PM
Senior Member
iTrader: (0)
 
Join Date: Apr 2005
Posts: 466
Butcher318 is on a distinguished road
Default

I had a Mirage 2950EX and it did not have the battery, nice radio.

Reply With Quote
  #4  
Old 04-08-2006, 02:27 AM
Junior Member
iTrader: (0)
 
Join Date: Mar 2006
Posts: 11
Texas Grizzly Bear is on a distinguished road
Default

Thanks HH for your post but I don't think it has anything to do with the speaker but I'll take a look at it you never know. I think it has more to do with the circuit board itís self since I noticed it only seem to start "acting up" when the daily temp goes up.

My radio doesnít have a battery either Butcher318; I think the big base radios Galaxy and RCI put out had the batteries. You know the RCI 2995, RCI 2980, and the Galaxy Saturn.

Guess itís time to take my radio in and have it looked at. Just wondered if any of you guys may have had any similar problems and knew what I might want to get my Tech to look for or where to start.

Thanks again,
Texas Grizzly Bear

Reply With Quote
  #5  
Old 04-08-2006, 04:12 AM
Happy_Hamer's Avatar
Forum Administrator
iTrader: (0)
 
Join Date: Mar 2001
Posts: 5,060
Happy_Hamer has disabled reputation
Default

Please take your covers off and look behind the frequency display

The battery is just under the black piezo-buzzer. The buzzer is stuck to it with double-sided tape...simply peel the buzzer off and there is the 3v coin-battery.
__________________
That's how I roll!!

Reply With Quote
  #6  
Old 04-12-2006, 09:11 AM
TonyV225's Avatar
W9WDX Amateur Radio Club Member
iTrader: (8)
 
Join Date: Apr 2005
Location: Wisconsin
Posts: 5,627
TonyV225 is on a distinguished road
Default

These radios also have problems with the CPU units. That processor has problems weird things can happen due to the fact that its the brain of that radio hopefully with any luck its not In lookinf for one now for a mirage 2950EX that I have the radio has worked flawlessly since 1997 until this CPU problem. Good luck and Im sure you will figure it out.....Tony
__________________
""""was not thinking of a cber sat with his makita screwdriver winding round the presets untill his meter said s9+60db from a guy on a handheld 15 miles away""""

Reply With Quote
  #7  
Old 04-12-2006, 09:55 AM
Senior Member
iTrader: (0)
 
Join Date: Apr 2005
Posts: 466
Butcher318 is on a distinguished road
Default

I think the Mirage 2950 EX version was updated and did not have the battery behind the display so his might have the battery. The only other problem I had was a cold solder joint from time to time.

Reply With Quote
Reply

Bookmarks
Worldwide Radio Forum



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 03:58 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Worldwide Radio Forum