Go Back   WorldwideDX Amateur Radio Forums > Citizens Band Related > CB Band and CB Radios


Amateur Callsign Lookup
Enter Callsign:

I have a Realistic TRC-482 and was wondering...

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-08-2008, 06:07 AM
Junior Member
iTrader: (0)
 
Join Date: Dec 2008
Posts: 4
The_Redneck_Man is on a distinguished road
Default I have a Realistic TRC-482 and was wondering...


Why when I first installed it into my car and I have a K2 antenna I think that is what type of antenna it is, not exactly sure. It's a 40 channel radio with WX 3 channels. I noticed after I installed it into my car, this was in a warm garage. It's a 7 footer too.

Then after it got real cold I noticed that the 4 lights for the tx and rx power lights when I am transmitting it goes one light when I push it down it and then it flickers to 2 lights and then goes back to one light after it is pushed all the way down, also sometimes when I talk into it it sometimes will flicker to 2 lights again but only for split second. It was fine when I first installed it in the garage? Please help me I would greatly appreciate it!


Reply With Quote
  #2  
Old 12-09-2008, 04:40 AM
Junior Member
iTrader: (0)
 
Join Date: Dec 2008
Posts: 4
The_Redneck_Man is on a distinguished road
Default

Hello can someone help me please it would be greatly appreciated thats for sure! Thanks

Reply With Quote
  #3  
Old 12-09-2008, 05:23 AM
BOOTY MONSTER
Guest
 
Posts: n/a
Default

if the vswr of the antenna is good and its not affecting what your transmission or recieve i wouldnt worry about it . it seems cosmetic . i would GUESS the led's are going bad or a dirty key on the mic .

Reply With Quote
  #4  
Old 12-09-2008, 05:28 AM
Junior Member
iTrader: (0)
 
Join Date: Dec 2008
Posts: 4
The_Redneck_Man is on a distinguished road
Default

Quote:
Originally Posted by BOOTY MONSTER View Post
if the vswr of the antenna is good and its not affecting what your transmission or recieve i wouldnt worry about it . it seems cosmetic . i would GUESS the led's are going bad or a dirty key on the mic .
Yeah it seems to send and recieve fine and the mic is the original mic that came with it and it is dirty. I haven't tested long distance though just 50 or 100ft or so. Thanks a lot an also I am wondering what the NB button that is on it does?

Reply With Quote
  #5  
Old 12-09-2008, 10:13 AM
iTrader: (11)
 
Join Date: Apr 2002
Posts: 8,178
Moleculo has disabled reputation
Default

NB is Noise Blanker. It helps cut out ignition noise or other motor noise that can into the RX of the radio.

Reply With Quote
  #6  
Old 12-09-2008, 04:45 PM
Junior Member
iTrader: (0)
 
Join Date: Dec 2008
Posts: 4
The_Redneck_Man is on a distinguished road
Default

Ok thanks a lot now I know and I greatly appreciate it that's for sure!

Reply With Quote
Reply

Bookmarks
Worldwide Radio Forum



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 12:39 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Worldwide Radio Forum