WorldwideDX Amateur Radio Forums

WorldwideDX Amateur Radio Forums (http://www.worldwidedx.com/forums.php)
-   HF Bands and HF Rigs (http://www.worldwidedx.com/hf-bands-hf-rigs/)
-   -   Kenwood ts-430s (http://www.worldwidedx.com/hf-bands-hf-rigs/30344-kenwood-ts-430s.html)

mackmobile43 09-13-2008 08:22 PM

Kenwood ts-430s
 
Ham Radio - Kenwood TS-430S Maintenance and Adjustment

jjk9 09-14-2008 05:18 AM

Excellent Video!!! Kudos

TonyV225 09-14-2008 06:16 PM

I had 2 of those Kenwood TS-430S they are great radios for there age

KE4YGS 10-29-2008 06:40 PM

Used to have an all matching 430 station. Never knew the freq set trick wtih WWV. Just tried it on my TS930 and it sure nuff is a tad off freq. Now to figure out where that little trimmer is on this radio......

Great instructional video !

Scotty

radiodawg259 11-28-2008 08:22 PM

Mack,i have a problem with the VFO knob it does not all change the freq. it will just stay and not change the numbers for several turns of the knob.It will just flash back and forth and then it will change several numbers,some time if i lift up on the knob it works like it should.Is it ok to call you Mack? By the way the radio is a TS-430.New to posting so bear with me.

mackmobile43 11-28-2008 08:31 PM

sounds like you might have a faulty vfo dial, you would want to contact a professional repair person.

radiodawg259 11-28-2008 08:32 PM

Thanks

74IN 11-28-2008 08:52 PM

Or part it out to buy a replacement.

Seems to happen alot on ebay.

I know where you could sell any filters you might have.:laugh:


All times are GMT -7. The time now is 08:42 PM.

Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Worldwide Radio Forum