1. In celebration of the launch of the new redesigned site, we just gave away a FREE antenna! Click Here to See Who Won!

no tx on cobra 29 ltd

Discussion in 'CB and Export Equipment and Accessories' started by scootter, Oct 18, 2010.

  1. scootter

    scootter Member

    Joined:
    Oct 18, 2010
    Messages:
    2
    Likes Received:
    0
    got a cobra 29 ltd no tx and no pa. changed final and driver but no change, you can hear mic key up on speaker but no power on meter and light go's out. it also has low power at t1 so i put in a new one but still low power like 4 to 5 watts, my other radio has 13 watts.:confused:


     
    #1
  2. Robb

    Robb Yup

    Joined:
    Dec 18, 2008
    Messages:
    8,214
    Likes Received:
    1,020
    5 watts peak output?
    There's a chance the the driver is what is showing that 5 watts; and the final isn't working. Seen that a couple of times. Could be something else; but I would check that first. If you have another final laying around - replace it.
     
    #2
  3. CTStallion

    CTStallion Active Member

    Joined:
    Aug 29, 2010
    Messages:
    196
    Likes Received:
    12
    No TX AND no PA, could be either microphone, mic jack, CB/PA switch or wiring, wiring from mic jack, and/or audio IC chip. I'd check those FIRST, and then move on from there.

    Once I got the PA function working, then I'd move on to the RF portion.

    Keep us posted.

    Good luck!
     
    #3
  4. The Jerk

    The Jerk Active Member

    Joined:
    May 6, 2008
    Messages:
    641
    Likes Received:
    49
    Does this sounds like a power supply issue?
     
    #4
  5. scootter

    scootter Member

    Joined:
    Oct 18, 2010
    Messages:
    2
    Likes Received:
    0
    no tx cobra 29ltd

    thanks guys for the help still checking it out,also trying to get my bench together. just got a tower for my antenna also trying to finsh the drywall in my new radio room. to many things to do and not enough time.(y)
     
    #5

Share This Page