1. In celebration of the launch of the new redesigned site, we just gave away a FREE antenna! Click Here to See Who Won!

Vista + THF6a + programming cable + USB serial adapter problem

Discussion in 'Ham Equipment' started by Moleculo, Aug 15, 2008.

  1. Moleculo

    Moleculo Administrator Staff Member

    Joined:
    Apr 14, 2002
    Messages:
    8,305
    Likes Received:
    527
    Has anyone seen this problem before?

    I went to update the programming on my kenwood THF6a using the kenwood programming cable + USB serial adapter. I tried both the Link 700 and the kenwood software. No matter what I do, it just won't read or update the radio anymore. It acts like it can't even talk to it. This was working fine, and I didn't change anything. I've tried checking the assigned serial ports, numerous settings, everything you can think of. The USB serial adapter works just fine with other equipment.

    I'm thinking it might be the kenwood cable, but i'm not sure how to test it to see? I've never seen a schematic for this cable. I'm about to try this on an XP machine to see what happens also.

    Oh yeah...one more thing...time for a brief rant....WTF is the deal with radio equipment manufacturers continuing to use serial interfaces?? Why can't they get with the program and use USB 2.0 intefaces like every other technology? I mean seriously...Serial has been dead for what, 10 years now? Good Grief!!!!


    #1
  2. W5LZ

    W5LZ Crotchety Old Bastard

    Joined:
    Apr 8, 2005
    Messages:
    6,834
    Likes Received:
    725
    Mole',
    Ran into this type of thingy (and still do) with Kenwood's 'TM-D700' program. The program and the Desktop computer have agreed that 'Com Port-4' is the place to look for how to get from here to there. (Serial cable to USB adapter thingy, the computer "finds" the proper USB port, and both agree to call it '#4'.) The laptop, being 'Vista', does things differently. Laptop and radio can't agree what goes where to start with, laptop asks "what's a #4?". After reminding (change Com Ports in the radio's program till you find the right one) Vista about that 'old' stuff, it says "Oh, yeah, Okay.", and goes looking for it, typically finds it just where it was, makes the 'connection' and away you go. Of course, after resetting for the laptop, the desktop has no idea what happened and you get to 'remind' it too. No idea why, but sometimes unplugging the USB cable, wait for the 'tone', then replugging it into the same USB port seems to be a 'Wake-Up' for the computer, makes it go looking before you tell it to, sort of.
    That's with the one particular program for the 'TM-D700' radio programming! Doesn't apply to the 'Link 700', or others like for Yaesu, etc. Remember, that particular program is something like 10 years old, has no idea what a USB port is, or a laptop computer. Once you 'get around' that, it works just like 'normal'. Unfortunately, just to introduce a little more confusion into this, there is a difference between, say, an 'Intel' processor and an 'AMD' processor, in how they do stuff like this. If the operating system designers (the real culprits) have done their jobs, the operator will never know anything 'extra' has happened.
    Oh, and one more little thingy. All USB to comport adapters are not created equal. Some will work when others get 'lost'. Just depends on what you are trying to do with them. I wish I could tell you which to use, but I can't (CRS thing, I think). The one I use works with the Kenwood programs, doesn't like the 'Link 700' program at all. Sort of aggravating...
    Good luck! Wish I had an absolute 'fix' for you but I don't. Mainly just wanted to let you know that you are not alone...
    - 'Doc
    #2


Share This Page