• You can now help support WorldwideDX when you shop on Amazon at no additional cost to you! Simply follow this Shop on Amazon link first and a portion of any purchase is sent to WorldwideDX to help with site costs.

emperor ts 5010 problem

CamoRedneck

KJ4PUF
Feb 28, 2008
87
2
18
54
SE Florida
Picked up the radio tonight. Was working good. Talked on it got good reports etc. Brought it home, hooked everything up and the radio does nothing. All you hear is a popping noise from the speaker. No lights etc.

Any idea what blew ?
 

davegrantsr

Active Member
Oct 30, 2005
593
84
38
Picked up the radio tonight. Was working good. Talked on it got good reports etc. Brought it home, hooked everything up and the radio does nothing. All you hear is a popping noise from the speaker. No lights etc.

Any idea what blew ?

KJ4 "PUF". that explains it. sorry ;-)
 

mechanic

Well-Known Member
Mar 4, 2009
596
125
53
North coast of the USA.... Da UP!
The eight volt regulator is notorious for having bad or cold solder joints, mounted on the side of the chassis frame. Also check B+ rails for any breakage or cracks, these come from the 12 volt input along the side of the pc board.

73 mechanic
 

bob85

Supporting Member
Mar 30, 2005
3,479
1,432
173
england
make sure you have not screwed a thumbwheel in too far and bust the trace that feeds the 8v regulator, i have had to fix a couple for locals with overlong thumbwheels.
 

TonyV225

W9WDX Amateur Radio Club Member
Apr 18, 2005
5,824
314
143
Wisconsin
:eek:MG yes people would do this all the time back in the mid 1990s I to have seen this first hand one was real bad. When theyu would by different thumb screws they would be to long and they would twist them in and hit the board by the thumb screw hole :eek:
 

dxChat
Help Users
  • No one is chatting at the moment.
  • @ Mark Malcomb:
    So true brother! Stay warm
  • @ 357:
    HkjspUX.jpg
  • @ AudioShockwav:
    BJ, were are experiencing record high temps for this time of year, they calling for a high of 65 today.
  • @ Greg T:
    You guys are amateurs! I got up to -14°F with a -39°F wind chill this morning!
  • @ ExitThirteen:
    woid.