1. You can now help support WorldwideDX when you shop on Amazon at no additional cost to you! Simply follow this Shop on Amazon link first and a portion of any purchase is sent to WorldwideDX to help with site costs.
    Dismiss Notice
Dismiss Notice
This forum does not allow a single user to have more than one username. If anyone wants to change their username contact an admin and it will be done. Multiple accounts belonging to the same member will be deleted without warning.

hr 2510 no am audio durnig transmit

Discussion in 'General CB Services Discussion' started by pumphouse, Sep 22, 2008.

  1. pumphouse

    pumphouse Active Member

    Joined:
    Sep 2, 2005
    Messages:
    116
    Likes Received:
    3
    got this problem, with my 2510.

    When i key up, on AM, I show a 10w output (on the bird) and the 2510 displays the bars (rf mode) but when i attempt to speak into my stock 2510 mic, there is no audio at all, just a dead key not even the beep comes thru. This is verified with a monitor radio. I even changed to a power mic. Same thing as above.



    But, check this out. When i key up on, LSB or USB, i faintly hear my audio comming thru the monitor radio. (the signal received by the monitor radio is very weak and the 2510 display shows no activity (no black bars) when transmitting on ssb. What the heck is going on here?

    Anyone ever have this same problem before? Where should I start to look?

    This 2510 is in such great shape. I would hate to see is tossed in the trash or being used for a parts radio.

    Thanks!,
    Pump
     

  2. nickr

    nickr Member

    Joined:
    Oct 7, 2009
    Messages:
    13
    Likes Received:
    11
    did you ever find out what the problem was?
    something similar seems to be happening to my lincoln.
     
  3. dx77HML

    dx77HML Member

    Joined:
    Jun 3, 2005
    Messages:
    64
    Likes Received:
    2
    Did anybody ever figure out the problem to this?I have a 2510 with no am modulation on it as well.Works fine on ssb.Any fix for it??

    Thank's
    Danny
     
  4. ExitThirteen

    ExitThirteen Grumpy and Cranky

    Joined:
    Apr 18, 2008
    Messages:
    1,963
    Likes Received:
    1,584
    Pump,

    Do you get any output at all out of SSB thru a wattmeter? Or just a small amount of faint audio from the receiver radio? Sounds like something's gone fault in the mic circuit somewhere, like a leaky capacitor, or possibly a regulator if SSB is functional.

    ~Cheers~
     
  5. dx77HML

    dx77HML Member

    Joined:
    Jun 3, 2005
    Messages:
    64
    Likes Received:
    2
    I found the problem finally.I replaced D-129 and Q-114 in the AMC circuit.Work's like a charm now.Before,SSB worked great.Great output.FM had audio out as well.Just was getting any audio on AM.Had power output just no modulation.
     

Share This Page

  • About Us

    The WorldwideDX Radio Forum was originally established in 2001. We pride ourselves on welcoming Radio Hobby enthusiasts of all types, while offering unbiased, informative, and friendly discussion among the members. We are working every day to make sure our community is the best Radio Hobbyist's site.
  • Like us on Facebook

  • Premium VIP Member

    The management works very hard to make sure the community is running the best software, best designs, and all the other bells and whistles. Care to buy us a beer? We'd really appreciate it!

    Donate to us!