• You can now help support WorldwideDX when you shop on Amazon at no additional cost to you! Simply follow this Shop on Amazon link first and a portion of any purchase is sent to WorldwideDX to help with site costs.
  • Notice: You may not use this site to facilitate the unauthorized selling of copyrighted material including, but not limited to, in the public dxForums, dxGallery, dxChat and private messsages. If you get caught doing this, you will be permanently banned with no second chances. A notice will be placed on the site of why you were banned and any information collected by this site about you will be made known to the copyright holder.

MFJ-4275MV 75 Amps Switching Power Supply Review

cobranut

Active Member
Dec 25, 2008
25
0
31
76
Does anyone know where the internal voltage adjustment is on the MFJ-4275MW power supply? The voltage on mine is a bit low at 13.2 volts at the detent setting. When I put about 45 amp load the voltage drops to 12.9 to 13.volts.
 

Moleculo

Ham Radio Nerd
Apr 14, 2002
9,043
1,348
283
It's not that unusual for a little voltage drop on these supplies when under load. It's not ideal, but it doesn't hurt anything.
 

Moleculo

Ham Radio Nerd
Apr 14, 2002
9,043
1,348
283
An update on this power supply: It's developed a strange problem where the output voltage is completely random and is dropping voltage pretty too much under load. It's become particularly annoying: one day the voltage output will be 15 volts; the next day it will be 12v without adjusting anything and without a change in load. I'm going to start moving stuff over the MegaWatt supplies and use this supply as a general garage unit.
 

hotrod

Well-Known Member
Feb 16, 2007
2,461
305
93
n.w pennsylvania
my jetstreame is doing similar . when i turn it on it reads differently than last time i used it. but when under load it doesnt move . those mega supplies i know nothing about other than pics on web. but got lotta quedtions
1/wheres power cord connection at for 110v
2/wheres power poles for hooking up devices to it
 

Moleculo

Ham Radio Nerd
Apr 14, 2002
9,043
1,348
283

Megawatt

Contributing Site Sponsor
Mar 25, 2015
58
48
28
62
California
www.12voltpowersupplies.us
my jetstreame is doing similar . when i turn it on it reads differently than last time i used it. but when under load it doesnt move . those mega supplies i know nothing about other than pics on web. but got lotta quedtions
1/wheres power cord connection at for 110v
2/wheres power poles for hooking up devices to it

There is good information on this site about the Megawatts and you can do a Google search as well or start a thread.
 

dxChat
Help Users
  • No one is chatting at the moment.
  • @ AudioShockwav:
  • @ kb9ghn:
    My first thought was the i.r.s. may be interested in a long term money making scam without proper taxes being paid..probably more than electronics involved.
  • @ Toll_Free:
    My first thought was why hasn't someone paid him a visit. I mean, his address is posted above.
  • @ beakster1715:
    Good news! I opened an appeal case after eBay sided with superhawkwss6. I also opened an IC3 case & sent that information to eBay. Within an hour they responded, reversed their decision and returned all of my money. Unfortunately, superhawkwss6 stole my CB radio and eBay will likely not suspend or close his account, but rather allow him to continue his criminal activity. I think I'll still file a report with our sheriff's dept (the sheriff is a friend of mine) though I know this type of crime isn't worth their time. This guy needs to be stopped and I'm certainly going to do my best to make that happen.
  • @ ButtFuzz:
    Good Evening!