• You can now help support WorldwideDX when you shop on Amazon at no additional cost to you! Simply follow this Shop on Amazon link first and a portion of any purchase is sent to WorldwideDX to help with site costs.

Scored another DX1600

TIN_CAN

Sr. Member
Nov 23, 2011
592
817
103
50
Well wife is not the happiest but I picked up a nice used Texas Star DX1600 with original Toshibas in it for $650 Canadian = $494US not bad really This was new just before they phased out the toshibas I think, as you can see its got the newer face plate then my other DX1600. I should also be getting the hopper 6 pill this week see how it does compared to the dx1600.

20201013-123551.jpg


20201013-123632.jpg


20201013-143948.jpg


20201013-143958.jpg
 

TIN_CAN

Sr. Member
Nov 23, 2011
592
817
103
50
Yeah looks nice and clean and orininal on the inside, anyone know what the #1007 is on the one on the left is?
 

999

Sr. Member
Apr 3, 2011
631
542
103
52
SF Bay Area
Yeah looks nice and clean and orininal on the inside, anyone know what the #1007 is on the one on the left is?
The production number of that model. TS did that on their amps for a long time. I'm not exactly sure when they stopped the practice.

Also note that your new one doesn't have the fuse holders in the back anymore. They phased them out on the latest runs. Mine is like that but still had the old style bias relay (on board 1 nearest the back). Yours already has the new style, Mine was sticking intermittently and I ended up swapping it for one of those and haven't had any issues since.
 
Last edited:
  • Like
Reactions: TIN_CAN

TIN_CAN

Sr. Member
Nov 23, 2011
592
817
103
50
Thanks for the reply , which opened my eyes to this modification... done by previous owner .. possible for my power supply resetting itself because of these extra fuses on pos + ? As my other dx1600 has glass fuses on back panel and no problem with resetting I am running a 150amp ps by the way.

20201013-192749.jpg


20201013-192757.jpg
 

999

Sr. Member
Apr 3, 2011
631
542
103
52
SF Bay Area
Thanks for the reply , which opened my eyes to this modification... done by previous owner .. possible for my power supply resetting itself because of these extra fuses on pos + ? As my other dx1600 has glass fuses on back panel and no problem with resetting I am running a 150amp ps by the way.

20201013-192749.jpg


20201013-192757.jpg
Yeaaaahhh....that is a bottleneck for sure. Get that garbage out of there and put some properly sized wire in with a 150A fuse and you should be good to go.
 

FredTx63

Well-Known Member
Oct 17, 2015
181
192
53
59
Thanks for the reply , which opened my eyes to this modification... done by previous owner .. possible for my power supply resetting itself because of these extra fuses on pos + ? As my other dx1600 has glass fuses on back panel and no problem with resetting I am running a 150amp ps by the way.

20201013-192749.jpg


20201013-192757.jpg

giphy.gif


I'd cut that shit clean off right there and get some real wire feeding that thing.
 
  • Like
Reactions: Shadetree Mechanic

dxChat
Help Users
  • No one is chatting at the moment.
  • @ BJ radionut:
    100W on FT8......1500W on CW/SSB
  • @ BJ radionut:
    We have a pronounced focus on human modes:ROFLMAO::cool:
  • @ BJ radionut:
    There will be NO FT8 robots running unattended at Bouvet,:ROFLMAO:
  • @ BJ radionut:
    10M BAND.....>28400 SSB .... Always give your full callsign. Listening is the key so be sure we call you before replying. 3Y0J will always listen up (using split) so it will be useless to call us on our transmission frequency.
  • @ BJ radionut:
    I like these guys already. :cool: Sounds to me like ROBO callers in ANY Mode will be ignored!!!!(y)