1. You can now help support WorldwideDX when you shop on Amazon at no additional cost to you! Simply follow this Shop on Amazon link first and a portion of any purchase is sent to WorldwideDX to help with site costs.
    Dismiss Notice

Diamond V2000 SWR Issue...

Discussion in 'Amateur Radio Antennas' started by KJ6REY, Oct 9, 2011.

  1. KJ6REY

    KJ6REY Member

    Joined:
    Oct 9, 2011
    Messages:
    3
    Likes Received:
    0
    I have had the Tri-Band (6m/2m/70cm) Diamond V2000a vertical for three weeks and have a strange SWR issue.

    The SWR on 6m and 2m is very low. Great!

    However, the SWR on 70cm is very high (over 4:1). Not good.



    I've checked all connections and grounding (with multimeter) and everything seems to be good.

    What would cause the two lower bands to have good SWR and the upper band would have a high SWR?

    NOTE: The 6m band has a tunable counterpoise, but 2m and 70cm is not tunable. Any thoughts?

    Thanks much!

    dave :blink:
     
    #1 KJ6REY, Oct 9, 2011
    Last edited: Oct 9, 2011

  2. bob85

    bob85 Supporting Member

    Joined:
    Mar 30, 2005
    Messages:
    2,896
    Likes Received:
    633
    you could remove the grubscrew at the base, slide the innards out a little and check none of the caps on the coil are damaged or unsoldered, i have fixed a few one piece versions but never looked inside the later two piece .
     
  3. KJ6REY

    KJ6REY Member

    Joined:
    Oct 9, 2011
    Messages:
    3
    Likes Received:
    0
    The base section seem glued tight. The rest looks ok, but I can't see the base with out breaking that seal. May look anyway. I have some weather tape.

    Thanks man.
     
  4. bob85

    bob85 Supporting Member

    Joined:
    Mar 30, 2005
    Messages:
    2,896
    Likes Received:
    633
    if its sealed its not like the ones i have repaired, on my one piece and a couple of locals the connector slides out once you remove the grubscrew,

    good luck.
     
  5. wa4gch

    wa4gch Active Member

    Joined:
    Sep 11, 2008
    Messages:
    120
    Likes Received:
    6
    My V2000
    was fine on 2 and 440 it was very narrow on 6 allowing only 52-53 mhz to be used.
     
  6. KJ6REY

    KJ6REY Member

    Joined:
    Oct 9, 2011
    Messages:
    3
    Likes Received:
    0
    My V2000a works great on 6 meters. I have Comet CA-00 antenna analyzer an tuned it for 53 Mhz for repeater activity. 2 meters functions great - even wider. However 70 cm is giving me the devil of a high SWR.

    I might break that seal at the bottom and see if there any problem there.

    Thanks for the reply. May someone out there has had this same issue too. It's a mystery.

    dave :confused:
     
  7. camerart

    camerart Member

    Joined:
    Feb 9, 2013
    Messages:
    23
    Likes Received:
    0
    Hi,
    Is this post still alive?

    I have opened my V2000 after getting a high SWR on 2mtrs. After some time of checking caps etc, I found a poor connector on the feeder.

    Here is the inside of the base of the antenna. Can someone give an outline of what the coil/caps do please?

    Camerart
     

    Attached Files:

Share This Page

  • About Us

    The WorldwideDX Radio Forum was originally established in 2001. We pride ourselves on welcoming Radio Hobby enthusiasts of all types, while offering unbiased, informative, and friendly discussion among the members. We are working every day to make sure our community is the best Radio Hobbyist's site.
  • Like us on Facebook

  • Premium VIP Member

    The management works very hard to make sure the community is running the best software, best designs, and all the other bells and whistles. Care to buy us a beer? We'd really appreciate it!

    Donate to us!