1. You can now help support WorldwideDX when you shop on Amazon at no additional cost to you! Simply follow this Shop on Amazon link first and a portion of any purchase is sent to WorldwideDX to help with site costs.
    Dismiss Notice
Dismiss Notice
This forum does not allow a single user to have more than one username. If anyone wants to change their username contact an admin and it will be done. Multiple accounts belonging to the same member will be deleted without warning.

Turner expander 500 mic- no audio

Discussion in 'CB and Export Equipment and Accessories' started by gmham555, Nov 21, 2020 at 12:39 PM.

  1. gmham555

    gmham555 New Member

    Joined:
    Jul 30, 2020
    Messages:
    5
    Likes Received:
    4
    Have a Turner expander 500 desk microphone here that I have just bought cheap, unfortunately although wired up correctly and fresh battery installed it’s producing no outgoing audio on my cobra 148gtldx. Meter on the microphone not moving on speech either. Battery test meter working. Going to try switch cleaner on the sliders failing that don’t know?!...anyone advise ?


     

  2. jessejamesdallas

    jessejamesdallas Sr. Member

    Joined:
    Apr 4, 2005
    Messages:
    1,448
    Likes Received:
    1,055
    How do you know it's wired correctly? Just because it has a 4 pin or 5 pin connector doesn't mean its wired right for your radio...specially a used mic that old.
     
  3. gmham555

    gmham555 New Member

    Joined:
    Jul 30, 2020
    Messages:
    5
    Likes Received:
    4
    Okay thanks for your reply and sorry yes appreciate a microphone of this age could have been retired or whatever in the 40 years it’s been out !
    Have actually found what I am sure is the source of the very problem, seems like an earth wire has detached itself from somewhere ! Not sure where if anyone can advise ? Wire is the one circled and is connected to the main cable that goes up to the mic element itself . Thanks guys.
     

    Attached Files:

  4. bob85

    bob85 Supporting Member

    Joined:
    Mar 30, 2005
    Messages:
    3,324
    Likes Received:
    1,218
    That's the audio wire from the mic cartridge,
    have a look on the board near the wire, you should be able to see where its broke off.
     
    jessejamesdallas likes this.
  5. gmham555

    gmham555 New Member

    Joined:
    Jul 30, 2020
    Messages:
    5
    Likes Received:
    4
    Thanks Bob found it , it’s the earth wire that hooked onto the metal clip where the mic cables exits the base. Cheers. John
     
    jessejamesdallas and bob85 like this.

Share This Page

  • About Us

    The WorldwideDX Radio Forum was originally established in 2001. We pride ourselves on welcoming Radio Hobby enthusiasts of all types, while offering unbiased, informative, and friendly discussion among the members. We are working every day to make sure our community is the best Radio Hobbyist's site.
  • Like us on Facebook

  • Premium VIP Member

    The management works very hard to make sure the community is running the best software, best designs, and all the other bells and whistles. Care to buy us a beer? We'd really appreciate it!

    Donate to us!