• You can now help support WorldwideDX when you shop on Amazon at no additional cost to you! Simply follow this Shop on Amazon link first and a portion of any purchase is sent to WorldwideDX to help with site costs.

Cobra 29XLR No Transmit

Space Cadet

Member
Jun 20, 2005
36
0
16
Midwest
I've got a Cobra 29XLR here that has got me confused. I can trace a 27mhz signal all the way to the base of the driver, but nothing on the collector except 12.2v (actually it is reading higher, around 13.4), and the audio. Definetly no rf though. Other than the slightly higher Vce, all the voltages look good on the entire tx circuit, from the oscillator to the final.... I have replaced both the final and driver, as well as various other caps and transistors, but there is still no transmit. RX and PA work. One other thing, when I stick a probe on the base of the driver, the rf can be heard in a nearby monitor rx, and the counter shows that the signal going into the base of the driver, from the oscillator, is right on frequency with regards to the channel selector...

Any ideas? What am I missing?
~Vince
 


dxChat
Help Users
  • No one is chatting at the moment.
  • @ Jim5570091:
    Maybe. I wasn’t impressed with just clamping the shield wire to the boom with a hose clamp. I built a l bracket with so239 female hubs. I posted a picture on the recent gallery’s.
  • @ Jim5570091:
    Well I cut the matching stubs down 1 inch at a time from about 20” down to 6”. Still no real changes.
  • @ 555 Central Missouri:
    Hello everyone, I have a old courier centurion pll 40 channel SSB, it has the extra channels and it has another switch that just moves the frequency down one channel on the dial, what is the purpose for this?
  • @ BJ radionut:
    LIVE 10:00 AM EDST