1. You can now help support WorldwideDX when you shop on Amazon at no additional cost to you! Simply follow this Shop on Amazon link first and a portion of any purchase is sent to WorldwideDX to help with site costs.
    Dismiss Notice

Galaxy 1000 amp arching

Discussion in 'Amplifiers' started by WHEELS, Apr 1, 2018.

  1. WHEELS

    WHEELS Member

    Joined:
    Mar 18, 2018
    Messages:
    14
    Likes Received:
    2
    Will definitely check those wires after work CB radio nut. As far as reflection , should've been there when I was taking pics. I was all thumbs , flash on , flash off, flash on auto, I deleted 2 times more pics then I used. :LOL: Thanks bud! At lunch now trying to find someone to test tubes. Do those tubes pull out like the tubes in guitar amps?


     

  2. WHEELS

    WHEELS Member

    Joined:
    Mar 18, 2018
    Messages:
    14
    Likes Received:
    2
    I will definitely check those blue wires radionut. Do those tubes just pull out? Watched a few videos but they only showed guitar amps. As far as the pics go that was a fiasco, flash off, flash on, flash on auto. I deleted twice as many pics than what I uploaded. Definitely not a photographer lol. Road squawker thanks for the info on the getter gas. Apparently my getter gas got gone and I need to get more. Hmmmmm say that 3 times in a row lol! BTW squawker, I had to google FWIW, guess I need to get with the times. Thanks again gents as your help and info are priceless. Keep up the great work. 73
     
  3. BJ radionut

    BJ radionut Supporting Member and 6m addict

    Joined:
    May 9, 2008
    Messages:
    2,434
    Likes Received:
    1,844
    Yep just wiggle them slightly pull up...they should come loose
     
  4. Chevboy0167

    Chevboy0167 Well-Known Member

    Joined:
    Apr 5, 2017
    Messages:
    279
    Likes Received:
    165
    Is it me or in images 2099 and 2100 of the underside, is that wire from the so239 jack to the board loose from the trace connection point and or the trace look burnt a ways down?
     
  5. nomadradio

    nomadradio Analog Retentive

    Joined:
    Apr 3, 2005
    Messages:
    3,026
    Likes Received:
    2,951
    Oops.

    Yes, I forgot to mention what that shiny spot is called.

    73
     
  6. WHEELS

    WHEELS Member

    Joined:
    Mar 18, 2018
    Messages:
    14
    Likes Received:
    2
    Tubes out, taking them to a local music repair shop to be tested. Thanks for the tips on taking them out. I am trying to get it fixed asap. But between raising 3 teenagers and keeping the wife happy, time to tinker is limited.
     
    Shadetree Mechanic likes this.
  7. 2315 Robert

    2315 Robert Grateful

    Joined:
    May 28, 2016
    Messages:
    257
    Likes Received:
    121
    Hey Wheels how have you made out?
     
  8. Road Squawker

    Road Squawker Sr. Member

    Joined:
    Jan 19, 2011
    Messages:
    1,710
    Likes Received:
    1,106
    Long time ago, when I worked in the "Glass" room at General Dynamics, (where we made REALLY high quality tubes,) We had a machine to activate the Getter material,............... of course, we called it the "Getter Blaster".
     
  9. WHEELS

    WHEELS Member

    Joined:
    Mar 18, 2018
    Messages:
    14
    Likes Received:
    2
    Tubes just got delivered to the house. Going to possibly work on it this weekend. I put the Antron on a 42ft. Tower this weekend. With a longer piece of coax. Ended up with 3+SWRs!!! Now gotta tear it down and find problem. I think it's the coax. The coax I am using is from the 70's. Belonged to my dad. Do y'all think I should invest in a dummy load to be on the safe side? I sure would hate to blow up/burn up some equipment.
     
  10. WHEELS

    WHEELS Member

    Joined:
    Mar 18, 2018
    Messages:
    14
    Likes Received:
    2
    Replaced coax swr are 1.1-1.3. I changed the driver tube to a NOS. Same number as old one. Replaced bad fuse in rear with the same amperage as old one. Except new one isn't slow blow. Wired it up, turned it on, let it warm up. While it was warming I noticed I had lost a lot of receive. With amp in bypass. After 5-6 minutes of warming up. Flipped switch on amp to low took amp out of bypass keyed mic, Radio started flashing "ANTENNA WARNING" arched on same relay then went dead........ checked fuse on rear it is blown. I removed the cover and at the tubes. They all appear in good condition .
     

Share This Page

  • About Us

    The WorldwideDX Radio Forum was originally established in 2001. We pride ourselves on welcoming Radio Hobby enthusiasts of all types, while offering unbiased, informative, and friendly discussion among the members. We are working every day to make sure our community is the best Radio Hobbyist's site.
  • Like us on Facebook

  • Premium VIP Member

    The management works very hard to make sure the community is running the best software, best designs, and all the other bells and whistles. Care to buy us a beer? We'd really appreciate it!

    Donate to us!