1. You can now help support WorldwideDX when you shop on Amazon at no additional cost to you! Simply follow this Shop on Amazon link first and a portion of any purchase is sent to WorldwideDX to help with site costs.
    Dismiss Notice

Realistic TRC-453, no modulation on AM, but SSB is ok.

Discussion in 'CB and Export Equipment and Accessories' started by Satelitte, May 30, 2013.

  1. Satelitte

    Satelitte Member

    Joined:
    May 30, 2013
    Messages:
    5
    Likes Received:
    0
    Hello everyone.
    I've got a problem with my Realistic TRC 453 (simillar to Uniden PC-122 Radio).



    It has no modulation on AM mode (carrier only), but on SSB mode everything is allright and modulated.

    So I am asking you. How I can fix it up?

    Driver, and PA transistors are OK.
    I picked a new capacitor 47uF near to the NE612 modulator and trying to resolder the area around.
    Turning the VR of AM mod changes nothing.
    :headbang

    Any ideas?

    73!
     

  2. sp5it

    sp5it Master of puppets

    Joined:
    Jul 9, 2009
    Messages:
    877
    Likes Received:
    377
    Replace TR544
    Mike
     
  3. Satelitte

    Satelitte Member

    Joined:
    May 30, 2013
    Messages:
    5
    Likes Received:
    0
    That's it!
    After a quick measurement I see it can be broken.
    (Drivers of it seems to be ok)

    Will be replaced soon.

    Dzięki Michał. 73
     
  4. Robb

    Robb Yup

    Joined:
    Dec 18, 2008
    Messages:
    10,657
    Likes Received:
    2,322
  5. Satelitte

    Satelitte Member

    Joined:
    May 30, 2013
    Messages:
    5
    Likes Received:
    0
    I'd rather put BD912 there. No problems with availability.
     
  6. Satelitte

    Satelitte Member

    Joined:
    May 30, 2013
    Messages:
    5
    Likes Received:
    0
    Hi guys it's me again.

    After replacement - it still doesn't work.
    There's about 8V when transmitting, on every single electrode of this transistor.
    It heats very much too.

    And there's only carrier and no mod.
     
  7. sp5it

    sp5it Master of puppets

    Joined:
    Jul 9, 2009
    Messages:
    877
    Likes Received:
    377
    Check TR36, 37, 38, D42.

    But first of it all remove C166 and check if there is any audio on R135.
    Mike
     
  8. Satelitte

    Satelitte Member

    Joined:
    May 30, 2013
    Messages:
    5
    Likes Received:
    0
    Still nothing... Can it be some issue with AM transformer? The carrier on AM is sometimes discontinuous.

    Thanks
     

Share This Page

  • About Us

    The WorldwideDX Radio Forum was originally established in 2001. We pride ourselves on welcoming Radio Hobby enthusiasts of all types, while offering unbiased, informative, and friendly discussion among the members. We are working every day to make sure our community is the best Radio Hobbyist's site.
  • Like us on Facebook

  • Premium VIP Member

    The management works very hard to make sure the community is running the best software, best designs, and all the other bells and whistles. Care to buy us a beer? We'd really appreciate it!

    Donate to us!