• You can now help support WorldwideDX when you shop on Amazon at no additional cost to you! Simply follow this Shop on Amazon link first and a portion of any purchase is sent to WorldwideDX to help with site costs.
  • Notice: You may not use this site to facilitate the unauthorized selling of copyrighted material including, but not limited to, in the public dxForums, dxGallery, dxChat and private messsages. If you get caught doing this, you will be permanently banned with no second chances. A notice will be placed on the site of why you were banned and any information collected by this site about you will be made known to the copyright holder.

FL-2000B High input SWR on 10 and 20m

Champo

Active Member
May 3, 2021
213
19
28
40
Oregon
I have a Yaesu FL-2000b that works other than the input SWR is high on 20m and in outer space on 10m. I was able to get 80m, 40m and 15m all below 2:1. 20m I can't get below 3.5:1 and 10m is so high it's hard to tell if it's 6:1 or more. I've focused on 10m so far since it's the worst. Both of the 100pf caps are good. I also replaced the Chinese tubes that were in it with NOS Cetrons in case it was tube related with no change. I tried tuning it on 30, 29, 28 and 27Mhz in case it had been messed with snd was no longer centered overthe middle of 10m. The factory adhesive that kept the slug in place was still intact on all bands but 10m. It had some issues when I acquired it. Also the band switch is clean as a whistle. No burnt contacts on the front or back of the band waffers. The coil/slug tracks with the 15m slug when the caps are removed as well and a VNA is used. Any help/ insight would be greatly appreciated.
 

kc8mob

Active Member
Sep 26, 2017
70
67
48
39
Not familiar with this unit specifically but maybe parasitic suppressors need replaced. Anything effecting the output in any way will effect the input.
 

Dmans

Sr. Member
Jan 22, 2017
1,265
1,534
173
Georgia
I've got an FL-2100B here to restore for someone else (after my much needed vacation!) that I know nothing of its operating condition. It does look original and very dirty internally.
I will not start on it until after Memorial Day but will update this thread with any information I find.

73
David
 
  • Like
Reactions: AudioShockwav

Champo

Active Member
May 3, 2021
213
19
28
40
Oregon
Much appreciated. The parasitic resistors were replaced. The individual I acquired it from replaced them originally with 22k metal oxide resistors rather than the 22ohm carbon resistors that are called for. He then lied about the symptoms the amp had. Not a big deal though. I didn't find out until I got it home that anytime the relay would key it would blow the fuse for obvious reasons. Easy fix. There are Allen Bradley 22ohm carbon resistors in there now. The only thing I can see at this point is perhaps the two door knob caps that are used for 10m are leaking under load despite testing properly. I order two replacements but they're coming from Eastern Europe so it'll be a hot minute before they arrive.

73's
Jacob
 

BJ radionut

Supporting Member and 6m addict
May 9, 2008
4,074
4,606
373
35 miles East of Indianapolis
 

Champo

Active Member
May 3, 2021
213
19
28
40
Oregon
Appreciate the info. Yeah that's why I ordered replacement caps (10 meter uses 2 door knobs) but it'll be a minute until they get here from Eastern Europe. They test correctly but who knows what's going on once they're under load. I have micas already to redo 80m and 40m (2 micas a piece) even though the swr is good on both. 15m uses 2 door knobs like10m but the swr on 15m is low (lowest of all the bands) so I'll leave it alone. 20m is interesting beause it uses 1 mica and one door knob. If swapping the mica doesn't reduce the swr on 20m then I'll wait to see if the door knobs fix 10m before ordering one for 20m.
 

Champo

Active Member
May 3, 2021
213
19
28
40
Oregon
NOMAD: Yes, Confusing Chris...think the FL2000 used 6KD6's
However, the FL2000B was early version FL2100 (y)
The version of the FL-2000B that I have uses 2 572b tubes. Not to say a previous iteration of it didn't. The FL-2000B is the amp that I've been discussing in this thread.
 

Attachments

  • Screenshot_20220514-135828_Gallery.jpg
    Screenshot_20220514-135828_Gallery.jpg
    1.1 MB · Views: 4
  • Screenshot_20220514-135925_Gallery.jpg
    Screenshot_20220514-135925_Gallery.jpg
    745.8 KB · Views: 5

dxChat
Help Users
  • No one is chatting at the moment.