1. You can now help support WorldwideDX when you shop on Amazon at no additional cost to you! Simply follow this Shop on Amazon link first and a portion of any purchase is sent to WorldwideDX to help with site costs.
    Dismiss Notice
Dismiss Notice
This forum does not allow a single user to have more than one username. If anyone wants to change their username contact an admin and it will be done. Multiple accounts belonging to the same member will be deleted without warning.

RM Station 550

Discussion in 'Amplifiers' started by redlght, Dec 17, 2016.

  1. bob85

    bob85 Supporting Member

    Joined:
    Mar 30, 2005
    Messages:
    3,281
    Likes Received:
    1,156
    3055's are low on gain and different pinout.
    Make sure you use the mica insulator under the 179.

    Good luck


     

  2. redlght

    redlght Active Member

    Joined:
    Feb 1, 2013
    Messages:
    128
    Likes Received:
    23
    Let's hope this works out all most a rebuild.

    No trees were harmed in the posting of this message...but a large number of electrons were put to their death.
     
  3. redlght

    redlght Active Member

    Joined:
    Feb 1, 2013
    Messages:
    128
    Likes Received:
    23
    got the right parts but r29 cooked again these amps are junk from the start as far as i am concerned
     
  4. LeapFrog

    LeapFrog Wielding Hanlon's Razor

    Joined:
    Feb 15, 2016
    Messages:
    1,690
    Likes Received:
    815
    Please excuse me for butting a suggestion in here, as I have not read this entire thread, but the original fault must still be present. (Whatever that is.)

    I don't want to be arrogant or seem all knowing, but something else must be awry.:censored:

    I agree with you, anything RM/Zetagi is probably low grade equipment and considered junk by many. [That said, they can perform & my RM 203 is running.. still.]
    (y)

    I hope the fault "pops out at you" one day so you can fix it, at times I'll set something down and forget about it for a while; When I return to it (sometimes days/weeks later) the fault becomes immediately apparent without further diagnosis!

    Best of Luck, 73!
     
    #79 LeapFrog, Jan 18, 2017
    Last edited: Jan 18, 2017
  5. redlght

    redlght Active Member

    Joined:
    Feb 1, 2013
    Messages:
    128
    Likes Received:
    23
    Well it is back working now i am at the bias issue once again
     
    LeapFrog likes this.
  6. LeapFrog

    LeapFrog Wielding Hanlon's Razor

    Joined:
    Feb 15, 2016
    Messages:
    1,690
    Likes Received:
    815
    Drive level is crucial, the lower the input (and less A.M. "swing kit") the better for these amplifiers.
    *Others may have suggested this earlier in the thread but I don't know if you tried lowering the input, or using another radio for a test?
     
    #81 LeapFrog, Jan 18, 2017
    Last edited: Jan 18, 2017
  7. redlght

    redlght Active Member

    Joined:
    Feb 1, 2013
    Messages:
    128
    Likes Received:
    23
    False alarm the 1 ohm went open again lol parts or repair sale coming up to much time onto this for me a few more times and ill toss it in.



    So far tr9 again or some thing near it drawing r29 to close to ground
     
    #82 redlght, Jan 18, 2017
    Last edited: Jan 18, 2017
  8. redlght

    redlght Active Member

    Joined:
    Feb 1, 2013
    Messages:
    128
    Likes Received:
    23
    Found that board was bowed putting a diode to ground fixed that used my last bd179 was working till i keyed up poofed another 1 ohm and the bd179 not gonna order more from the uk and wait weeks i toss in the towel on this basket case.

    IMO if you run a crossed a station 550 or klv 550 base amp run as fast as you can the other direction at any price.

    P.S. The amp still outputs just does not have a bias circuit been the whole problem ever since.
     
    #83 redlght, Jan 18, 2017
    Last edited: Jan 18, 2017
  9. redlght

    redlght Active Member

    Joined:
    Feb 1, 2013
    Messages:
    128
    Likes Received:
    23
    I used the mica ..ever run up on that schematic? thanks
     
  10. redlght

    redlght Active Member

    Joined:
    Feb 1, 2013
    Messages:
    128
    Likes Received:
    23
    I have noticed the voltage on R29 is at 38.6 volts, is that any where near the correct voltage? The voltage right out of the bridge is 39 volts.
     
  11. Tallman

    Tallman W9WDX Amateur Radio Member, KW4YJ EXTRA class

    Joined:
    May 1, 2013
    Messages:
    5,123
    Likes Received:
    5,842
    Can you send me a copy of the schematic? I can help you fix this amp.
     
  12. bob85

    bob85 Supporting Member

    Joined:
    Mar 30, 2005
    Messages:
    3,281
    Likes Received:
    1,156
    Ignoring the no bias at low drive levels issue 550 biasing is usually reliable.

    39v is 9v higher than the 550's i have worked on.
    Normal is 30v with no drive dropping to 25.5v @300w FM.

    Of course that's going to effect the idle current and @ what drive level the bias turns on.
     
  13. redlght

    redlght Active Member

    Joined:
    Feb 1, 2013
    Messages:
    128
    Likes Received:
    23
    39 volts high enough to short TR9 blow out r29? and why do i get 26 ac volts in to bridge and 39 dc out?
    Taking filter caps out of line i get 26 AC in to bridge and 31 DC out, where is the voltage drop i should see a crossed the didoes?
     
    #88 redlght, Jan 19, 2017
    Last edited: Jan 19, 2017
  14. bob85

    bob85 Supporting Member

    Joined:
    Mar 30, 2005
    Messages:
    3,281
    Likes Received:
    1,156
    I never ran one up to 39v to find out but its well above the transistors max rating & the bias circuit is fed from the same supply.

    I would disconnect the bias circuit output from the transistors.
    manually key it to see if it still smokes the 1 ohm.

    The 550 uses a full wave bridge rectifier you should get 1.414 x the transformer secondary voltage on the smoothing caps.

    Theres nowhere near enough capacitance for the current it has to supply,
    Voltage is up and down like a fiddler's elbow with changes in drive level.

    I don't have the flash drives with schematics here or a computor if i did.
     
    #89 bob85, Jan 19, 2017
    Last edited: Jan 19, 2017
  15. redlght

    redlght Active Member

    Joined:
    Feb 1, 2013
    Messages:
    128
    Likes Received:
    23
    right now i am fresh out of bd179's
     

Share This Page

  • About Us

    The WorldwideDX Radio Forum was originally established in 2001. We pride ourselves on welcoming Radio Hobby enthusiasts of all types, while offering unbiased, informative, and friendly discussion among the members. We are working every day to make sure our community is the best Radio Hobbyist's site.
  • Like us on Facebook

  • Premium VIP Member

    The management works very hard to make sure the community is running the best software, best designs, and all the other bells and whistles. Care to buy us a beer? We'd really appreciate it!

    Donate to us!