• You can now help support WorldwideDX when you shop on Amazon at no additional cost to you! Simply follow this Shop on Amazon link first and a portion of any purchase is sent to WorldwideDX to help with site costs.
  • Notice: You may not use this site to facilitate the unauthorized selling of copyrighted material including, but not limited to, in the public dxForums, dxGallery, dxChat and private messsages. If you get caught doing this, you will be permanently banned with no second chances. A notice will be placed on the site of why you were banned and any information collected by this site about you will be made known to the copyright holder.

New 667V issues

sp5it

Master of puppets
Jul 9, 2009
2,154
2,563
273
Poland
www.qrz.com
Hi guys.
Is it already converted? A friend sent mi that amp to do conversion, but it seems it's already done.
CameraZOOM-202008081440_1.jpg
Mike
 

Handy Andy

Do Your Research First, Then Decide...
Apr 23, 2018
5,583
7,693
573
www.cbtricks.com
Thanks for the Pic...

This is that mod where the area is, what those Vids show...
TexasStar667Mod.jpg

In that amp they show they are soldered...so to prevent another problem...

Turn the amp on it's side and look at the board - side view - to make sure they did not PUSH those caps into the HEAT SINK - shorting out that section - preventing it form working - shorted out the input - kinda' thing.
 
  • Like
Reactions: tecnicoloco

sp5it

Master of puppets
Jul 9, 2009
2,154
2,563
273
Poland
www.qrz.com
I got a problem with that amp.
When transmitting to dummy load or antenna SWR goes sky high. No matter AM or SSB.
Amp is brand new, no sign of any damage.
Anyone saw that issue before? Parasitic oscillation, bad relay?
Mike
 

ExitThirteen

Grumpy and Cranky
Apr 18, 2008
1,965
1,634
173
Cornpatch of Iowa
It appears as though there are no tuning capacitors on the output side of the amp, nor is there a tuning capacitor between the driver and the finals. I'd suspect that's the issue. Unfortunately, Texas Star has really dropped the ball when it comes to the new amps, they just throw the DEI transistors in and don't bother to re-tune the input and outputs, and the DEI's do NOT tune the same as the old Toshiba transistors. Looks like you're going to have to some re-tuning to do.


~Cheers~
 
  • Like
Reactions: tecnicoloco

sp5it

Master of puppets
Jul 9, 2009
2,154
2,563
273
Poland
www.qrz.com
Ok, after some diagnosis it is oscillation for sure. After 30MHz lowpass SWR is fine.
Could you point me where to look for a tuned circuit sample usage? Maybe I could copy that circuit from other amp?
Mike
 

ExitThirteen

Grumpy and Cranky
Apr 18, 2008
1,965
1,634
173
Cornpatch of Iowa
Handy Andy is indeed right, that does not look correct. Here are the spots that you may need to add capacitance. The first set of arrows in white is at the input, the yellow set is at the output combiner, the green set is between the driver and final section. It's best to use a 465 ARCO adjustable compression trimmer capacitor to dial things in, then swap out to mica capacitors (@500V) of the value you dial it to. I've had to do this on a few 667's with SWR issues, and they've all come out very well. Also, the driver section circled in light blue is absolutely the worst, most garbage design I've ever seen, and likely the culprit of all of the oscillation/SWR issues you're having. Old 667V's had a 2SC2290 in place of the MOSFETS, with proper biasing at the base of the 2290... these FETs don't appear to have any sort of real bias on them at all... trash.

667V.jpg

~Cheers~
 
Last edited:

Handy Andy

Do Your Research First, Then Decide...
Apr 23, 2018
5,583
7,693
573
www.cbtricks.com
I've been doing comparisons,
Because if this is something new, I'll need to learn this too...
upload_2020-8-9_10-57-25.png

And the other half of mainboard
TS667V3of2.jpg

Several things...

One, Location of R3 and what it's connected to - 75 ohm - Power?

Note 4 states; Trace is cut, R3 covers that section...

I'm working this right along with you...unfortunately I don't have a REAL one in front of me to help...

Considering what is on You Tube, makes me wonder if they "make changes" and randomly alter these parts...

The MOSFET input section DRIVER - to the amp, scares me...
 

Attachments

  • TS667V2of2.png
    TS667V2of2.png
    1.8 MB · Views: 91
  • Like
Reactions: Shadetree Mechanic

dxChat
Help Users
  • No one is chatting at the moment.
  • @ AudioShockwav:
  • @ kb9ghn:
    My first thought was the i.r.s. may be interested in a long term money making scam without proper taxes being paid..probably more than electronics involved.
  • @ Toll_Free:
    My first thought was why hasn't someone paid him a visit. I mean, his address is posted above.
  • @ beakster1715:
    Good news! I opened an appeal case after eBay sided with superhawkwss6. I also opened an IC3 case & sent that information to eBay. Within an hour they responded, reversed their decision and returned all of my money. Unfortunately, superhawkwss6 stole my CB radio and eBay will likely not suspend or close his account, but rather allow him to continue his criminal activity. I think I'll still file a report with our sheriff's dept (the sheriff is a friend of mine) though I know this type of crime isn't worth their time. This guy needs to be stopped and I'm certainly going to do my best to make that happen.
  • @ ButtFuzz:
    Good Evening!