• You can now help support WorldwideDX when you shop on Amazon at no additional cost to you! Simply follow this Shop on Amazon link first and a portion of any purchase is sent to WorldwideDX to help with site costs.

texas star 400

The amp gods have spoken, don't keep using it unless you like buying new transistors at 40-50 dollars a piece!! Send it to a good amp repairman and get it fixed! There is a guy I know that is a heck of a builder/repairman that is on the forum here and is right under your nose!! Maybe if you ask about getting it fixed he will help you out. Just my 2 pennies!!
 
  • Like
Reactions: Crusher
At least you have proof that you have Fire in the wire & your Blowin Smoke. :rolleyes: If the rely is sticking the contacts could be dirty, but with all the smoke coming off that thing I wouldn't run it your degrading the components. Find a "Good Radio Tech" not some TS golden screwdriver, to go through the amp and correct the problem and have the radio to set up for it by the same person so you're not overdriving it.
 
[QUOTE="222DBFL, post: 504401, member: sendd it to a good amp repairman and get it fixed! There is a guy I know that is a heck of a builder/repairman that is on the forum here and is right under your nose!! Maybe if you ask about getting it fixed he will help you out. Just my 2 pennies!![/QUOTE]

Exit Thirteen or Crusher both have in depth knowledge of solid state amps, if they have time to work on it.
 
  • Like
Reactions: 222DBFL and Crusher
It was pretty apparent in the video that the last pill in the back was blown and its 10 ohm bias resistor was cooking and smoking causing the output combiner to smoke too.
 

dxChat
Help Users
  • No one is chatting at the moment.
  • @ Wildcat27:
    Hello I have a old school 2950 receives great on all modes and transmits great on AM but no transmit on SSB. Does anyone have any idea?
  • @ ButtFuzz:
    Good evening from Sunny Salem! What’s shaking?
  • dxBot:
    63Sprint has left the room.
  • dxBot:
    kennyjames 0151 has left the room.