• You can now help support WorldwideDX when you shop on Amazon at no additional cost to you! Simply follow this Shop on Amazon link first and a portion of any purchase is sent to WorldwideDX to help with site costs.
  • Notice: You may not use this site to facilitate the unauthorized selling of copyrighted material including, but not limited to, in the public dxForums, dxGallery, dxChat and private messsages. If you get caught doing this, you will be permanently banned with no second chances. A notice will be placed on the site of why you were banned and any information collected by this site about you will be made known to the copyright holder.

wcsd106

Active Member
Nov 19, 2009
246
4
28
Good morning,

Short Version (More detailed version below)


Problem: Icom 706MKiiG will not turn on.

Steps Taken So Far:

  • Verified that power cord works on my spare 706mkiig
  • Verified that the control head works on my spare 706mkiig
  • Tried working control head on dead radio
  • Opened case and verified fuse is good and voltage making it past fuse
  • Checked underneath PLL board for corrosion and cut trace(s) - Corrosion present, traces OK however
Detailed Version:
I've had an Icom 706MKiiG in my truck for the past 8 years or so. I haven't used it in the past couple of years, but it's still been there mounted safely under the rear seat with the remote cable running to the control head under the center of the dash.

To make a long story short, I recently got a new truck and removed all my radio equipment and personal belongings out of my old truck yesterday. The reason I hadn't used the 706 in a long time was because a ground issue was keeping the radio from operating correctly. (Worked fine on RX, but the minute you tried to transmit i.e. draw more amperage.. the radio would freak out and lock up requiring you to remove the power cord and reset it.) I never got around to running a ground wire directly to the battery, just stopped using the radio.

Yesterday afternoon when I got home, I put the radio on my bench to check it out and noticed that it will no longer power up at all. No sound of any relays, no nothing. Dead in the water.

Now, I have another 706mk2g and I hooked it up using this same power cord and it works perfectly. I also removed the control head from the radio in question and it works fine on the other mk2g, so we can probably rule out problems with the control head.

I opened the case, and I am getting 13.8v past the fuse, so it's good, but the radio still isn't turning on or even trying to. I've read multiple instances of the rubber insulators under the pll board eating away at the pll board to the point of chewing up a trace. I checked that yesterday and the traces are good. Verified with a magnifying lens and a multimeter.

Not sure where else I can check and there doesn't seem to be a lot of folks working on the mk2g anymore as it is getting older.

I'm hoping someone has some common areas for me to check and can help me get this rig back up and running.

Thanks.
 

Shadetree Mechanic

808 On The North Side of Dover
Oct 23, 2017
4,931
7,907
623
50
The First State (Delaware)
I don't know anything about this radio, but I am tuned in to see what the fix is. Sounds like something is shorted like the final. And when keyed, it causes the voltage to drop and that is why it goes goofy. Just a guess.
 

wcsd106

Active Member
Nov 19, 2009
246
4
28
The going goofy was likely a bad ground for the power cord. It only did that in the truck. On the bench it worked correctly.

Now it's simply not powering up at all. No relay clicks, no nothing.
 

w9cll

W9WDX Amateur Radio Club Member
Jan 19, 2013
4,418
3,886
273
Chicago, IL
www.flickr.com
The 706 is very sensitive to power and will not turn on if the voltage is too far above 12v or to far below it. It sounds like yo did a lot of testing and my gut feeling it's dead. Sad part of the is parts are not readily available anymore.
 

nomadradio

Analog Retentive
Apr 3, 2005
5,316
7,637
573
Louisville, KY
www.nomadradio.com
Pretty sure the power button is not a traditional switch mechanism in line with actual power supply.

It's a command input to a microprocessor. If it boots up, it turns on the main power relay.

Pretty sure. You did hear a slightly-delayed "click" from inside when it would power up, didn't you?

If the microcontroller chip is not running its program, no power up.

Found an article on mods.dk about the 706 restarting spuriously. He cleaned/tightened the radio's internal coax and flat-cable connections.

Can't post a direct link to it, unless you're signed in to mods.dk.

But that's the gist. A look at their list of 'mod' articles shows one about "restart". That's the one.

Cheapest thing to try first.

73
 

wcsd106

Active Member
Nov 19, 2009
246
4
28
Thanks, Nomad.

In actuality, no I'm not hearing the faint relay click that should occur when power is applied.
 

nomadradio

Analog Retentive
Apr 3, 2005
5,316
7,637
573
Louisville, KY
www.nomadradio.com
Not good. Either the relay itself is bad, or the computer isn't telling it to turn on.

Makes me wonder if you can reach the two wires that go to the power switch. If they are accessible, bridging across them with a screwdriver tip would tell you if the push button itself is failing to close a circuit.

73
 

wcsd106

Active Member
Nov 19, 2009
246
4
28
Nomad,

I've tried two separate control heads, both of which work fine on my good 706mk2g... Leaning towards a bad relay.
 

Robalo

Well-Known Member
Aug 21, 2006
584
228
53
California
Working on Ic-706Mkii like new but won’t turn on
 

Attachments

  • 5A9A9308-BC20-4B0A-B3D5-A7E027083ABD.jpeg
    5A9A9308-BC20-4B0A-B3D5-A7E027083ABD.jpeg
    1.2 MB · Views: 121
  • 47715526-7259-4210-8803-27F71DEFCBB5.jpeg
    47715526-7259-4210-8803-27F71DEFCBB5.jpeg
    1.3 MB · Views: 125
  • 28EEC12B-5D00-4871-B100-8CF6175A26A3.jpeg
    28EEC12B-5D00-4871-B100-8CF6175A26A3.jpeg
    950 KB · Views: 112

nomadradio

Analog Retentive
Apr 3, 2005
5,316
7,637
573
Louisville, KY
www.nomadradio.com
Time for a 'scope. First, finding the power to the controller chip that listens for the power button. If that's okay, there should be a logic high level, either 3 Volts or 5 Volts on one side of the power button. The other side of the power switch is probably ground. Seeing the 'off' voltage, and seeing it fall to zero when you push the button would confirm you have a good input to the controller chip.

Didn't dig through the diagram to see what pin of the controller feeds out to a transistor that enables the power relay. But you get the idea. Start at the switch and follow the sequence of events from there.

A voltmeter won't tell you if there is noise or ripple on the power supply of the controller chip. Never learned any other way to do this but with a 'scope.

73
 

Robalo

Well-Known Member
Aug 21, 2006
584
228
53
California
there's power at PA,but not at main board, every thing start with short on the ribbon cable from pll unit J2 to main unit J13 all my test tell me the problem is IC 25 main micro ship. just got it on line.just don’t out the D132 and Q82 are bad now is time for shopping.Q82 is DTA114EE SÍMBOLO 14 and D132 is DAN 222 símbolo N
 

Attachments

  • CDCAD146-04E4-4858-A900-CE7E557DD56A.jpeg
    CDCAD146-04E4-4858-A900-CE7E557DD56A.jpeg
    1.5 MB · Views: 115
  • 7181DCCD-480E-4A3D-A39E-ED60144A7F0E.jpeg
    7181DCCD-480E-4A3D-A39E-ED60144A7F0E.jpeg
    656.8 KB · Views: 123
  • 36C1F659-AD16-4122-B89F-1163338DE4DF.jpeg
    36C1F659-AD16-4122-B89F-1163338DE4DF.jpeg
    1.5 MB · Views: 102
  • 29B819E4-D7ED-4ABB-ADD2-BD034B3935FF.jpeg
    29B819E4-D7ED-4ABB-ADD2-BD034B3935FF.jpeg
    2.2 MB · Views: 99
Last edited:

nomadradio

Analog Retentive
Apr 3, 2005
5,316
7,637
573
Louisville, KY
www.nomadradio.com
Q82 may very well be bad, if that's the scorched-looking one.

But it has nothing to do with turning on the main power relay. This is looking more like a radio that was connected to the antenna during a storm. Q82 activates the band pass filter relays for band "L3".

The highlighted pin on the connector J621 leading to the PA module marked "POWS" looks likely as relating to power switching. But that leads off to another connector J1381 marked "Main (3)". Didn't track it further on the Main board.

Burned parts just suggest a lightning surge. Could have come down the coax when a neighbor's tree was struck, or by way of the power line if it struck a nearby pole.

Lightning tends to cause weird faults.

73
 
  • Like
Reactions: Robalo

Robalo

Well-Known Member
Aug 21, 2006
584
228
53
California
freecell is now following you. LOL :LOL::) Maybe I going to destroy that beatifull radio:LOL:. well Iam working on the PA right now with relay 2 the bad part is D14 an or D 11
 

Attachments

  • 6A1B80CE-FDCD-4B7B-A101-F1388C667A8C.jpeg
    6A1B80CE-FDCD-4B7B-A101-F1388C667A8C.jpeg
    1.9 MB · Views: 80
  • 831768A4-E14F-470C-9FC7-E79109A68B0B.jpeg
    831768A4-E14F-470C-9FC7-E79109A68B0B.jpeg
    804.5 KB · Views: 80
  • 9BD019FA-B1BE-4630-AE75-79E6709AB34A.jpeg
    9BD019FA-B1BE-4630-AE75-79E6709AB34A.jpeg
    594.3 KB · Views: 81
  • 29CA21BC-763A-45CC-8A56-08812E0D29EF.jpeg
    29CA21BC-763A-45CC-8A56-08812E0D29EF.jpeg
    2.1 MB · Views: 87
  • 637ECB12-0D09-4A75-9AEA-822EBDA4A532.jpeg
    637ECB12-0D09-4A75-9AEA-822EBDA4A532.jpeg
    773.1 KB · Views: 101
Last edited:

dxChat
Help Users
  • No one is chatting at the moment.